#1 2014-07-26 10:59:59

mrozk777
Участник
Зарегистрирован: 2014-07-26
Сообщений: 1

В плате Arduino Gboard одновременно не работает SD и SIM900

В плате Gboard одновременно не работает SD и SIM900. По отдельности все хорошо работает: запись/чтение SD и SIM900  . Когда пытаюсь сделать запись или чтение SD при включенном SIM900 Gboard перезагружается. Питание идет чере плату Foca 5В. Подскажите пожалуйста кто знает в чем причина

Редактировался mrozk777 (2014-07-26 11:01:27)

#2 2014-07-27 12:24:00

NoName
Customer
Из Київ
Зарегистрирован: 2014-07-08
Сообщений: 1,446

Re: В плате Arduino Gboard одновременно не работает SD и SIM900

день добрый,  схема принципиальная есть? если есть - нужно показать )
я бы копал в сторону "просадок" по питанию  - например супервизор может дать ресет, при запуске модуля,  в пике, игла потребления может дать 2А   +  карточка менее жрущая но все же.
либо короткое замыкание.  что опять же приводит к ресету по питанию.  но и программных заморочек никто не отменял.

#3 2014-08-17 14:47:19

admin
Administrator
Из Киев
Зарегистрирован: 2014-06-09
Сообщений: 56

Re: В плате Arduino Gboard одновременно не работает SD и SIM900

Согласен с NoName - для начала я бы запитал плату от надежного БП и устранил вероятность просадки питания.

#4 2014-09-26 19:04:02

motin.maxim
Участник
Из Киев
Зарегистрирован: 2014-08-01
Сообщений: 17
Сайт

Re: В плате Arduino Gboard одновременно не работает SD и SIM900

Там еще такая штука, я с ней парился. Только я брал готовый шилд 9000. 2 и 3 пины цифровые заняты softwareserial,  и по мануалу 7,8,9 тоже используются шилдом. Вот на них у меня и висел экран. Может у вас что то подобное.

Быстрое сообщение

Введите сообщение и нажмите Отправить

Подвал раздела